Zoomdata Version

System Requirements

Zoomdata can be downloaded and installed in different Linux distributions. You can also deploy Zoomdata in the cloud . To learn about Zoomdata's Cloud deployment options, refer to our Free Trials information page.

The client application is accessed using web browsers that support web socket technology. See caniuse.com to check whether your web browser supports web socket technology. The following requirements are needed in order to successfully deploy and access the Zoomdata Server in your operating environment.

See also Installation Prerequisites.

Operating System and Software Requirements

For Linux deployments, 64-bit Linux-based OS is required. The following table shows the Linux distributions supported along with the corresponding minimum supported version. Zoomdata Server also uses Java, PostgreSQL, and Spark. Ensure that the appropriate version of these tools are used in the deployment of Zoomdata in your operating environment.

Distribution Minimum Supported Version
CentOS 6.5
Red Hat 6.5
Scientific Linux 6.5
Ubuntu 14.04, 16.04 LTS
PostgreSQL 9.5
Java 8 (1.8.0_131 or later)
Spark 2.2

Hardware Requirements

For RPM and Ubuntu installations, the following server specifications are recommended:

  • 64 GB RAM (minimum is 16 GB)
  • 500 GB disk space
  • 16 cores

Network Requirements

Ports

By default, the Zoomdata Server uses port 8080. However, you have the flexibility to configure Zoomdata to use different ports. The following options are available:

  • For HTTPS requests, configure your firewall to map port 443 to either (1) 8443 or (2) 8080

Essentially, you can configure the Zoomdata Server so that only one or two ports are open externally (to the general public) once your configuration is complete. For more information, see Configuration Property Files and Their Corresponding Values.

Time Synchronization

Zoomdata recommends installing the Network Time Protocol daemon (NTPD) to allow for time synchronization of networked servers to Coordinated Universal Time (UTC), if not already available in your network. See Using the Network Time Protocol to Synchronize Time for guidance.

Supported Browsers

Due to the WebSocket technology that Zoomdata uses, you need to use one of the following browsers to access the client application.

Windows 7+

  • Chrome 49+ (recommended)
  • Firefox 45+
  • Edge 14+
  • Internet Explorer 11+

Mac OSX 10.10+

  • Chrome 49+ (recommended)
  • Firefox 45+
  • Safari 9.1+

iOS 9+ on iPad

  • Embedded Safari Browser

Android 6+

  • Embedded Chrome Browser

Was this topic helpful?