Zoomdata Version

Migrating Connectors for Other Zoomdata Versions

Zoomdata 4.1 introduced a new microservice registration model for connectors. The new model is not fully compatible with earlier versions of Zoomdata. Special migration steps must be performed if you want to use a:

Zoomdata 3.2 to 4.0 connectors are fully compatible with Zoomdata versions 4.1 and later.

Using a 4.1 (or Later) Connector With Zoomdata 4.0 (or Earlier)

Before you can use a Zoomdata 4.1 (or later) connector with Zoomdata 4.0 (or earlier), you must complete the following migration steps.

  1. Contact Zoomdata Technical Support to obtain the code for the Zoomdata 4.1 (or later) connector you want to use.

  2. Install the Zoomdata 4.1 (or later) connector supplied by Technical Support.

    $ sudo yum install <zoomdata-edc-connector>
  3. Make sure you have a copy of the connector's property file in /etc/zoomdata. The supported property file names are listed in Connector Properties. If the property file does not exist in /etc/zoomdata, copy the file from /opt/zoomdata/conf. If the property file does not exist in /opt/zoomdata/conf, then just create the file (using the supported name) in the /etc/zoomdata folder.

  4. Edit the connector's property file in the /etc/zoomdata folder and change the value of the spring.application.name property to edc.

    ...
    spring.application.name=edc
    ...
  5. Save the property file and start or restart the appropriate connector microservice.

    $ sudo systemctl start <connector-service-name>

    See Starting Zoomdata Microservices and Restarting Zoomdata Microservices for more information. Microservice names are listed in Zoomdata Microservice Name Reference.

The Zoomdata 4.1 (or later) connector will now work with your earlier version of Zoomdata.

Using a 3.1 (or Earlier) Connector With Zoomdata 4.1 (or Later)

Before you can use a Zoomdata 3.1 (or earlier) connector with Zoomdata 4.1 or later, you must complete the following migration steps.

Zoomdata 3.2 to 4.0 connectors are fully compatible with Zoomdata 4.1.
  1. Contact Zoomdata Technical Support to obtain the code for the Zoomdata 3.1 (or earlier) connector you want to use.

  2. Install the Zoomdata 3.1 (or earlier) connector supplied by Technical Support.

    $ sudo yum install <zoomdata-edc-connector>
  3. Make sure you have a copy of the connector's property file in /etc/zoomdata. The supported property file names are listed in Connector Properties. If the property file does not exist in /etc/zoomdata, copy the file from /opt/zoomdata/conf. If the property file does not exist in /opt/zoomdata/conf, then just create the file (using the supported name) in the /etc/zoomdata folder.

  4. Edit the connector's property file in the /etc/zoomdata folder and add the following properties.

    ...
    spring.cloud.consul.discovery.health-check-path=/actuator/health
    management.context-path=/actuator
    management.health.consul.enabled=false
    ...
  5. Save the property file and start or restart the appropriate connector microservice.

    $ sudo systemctl start <connector-service-name>

    See Starting Zoomdata Microservices and Restarting Zoomdata Microservices for more information. Microservice names are listed in Zoomdata Microservice Name Reference.

After the Zoomdata 3.1 (or earlier) version connector microservice starts and has been registered, Zoomdata automatically converts its address, port, and tags as necessary to register the connector using the new connector microservice registration model. The Zoomdata 3.1 (or earlier) connector will then work with Zoomdata 4.1 (or later).

Was this topic helpful?