Zoomdata Version

What Is This Unsupported Class Error?

The UnsupportedClassVersionError: Main : Unsupported major.minor version 52.0 error typically occurs when the Java version with which the plug-in is compiled differs from the Java version that the Zoomdata server is using. Zoomdata and its related plug-ins are compiled using Java 8 (1.8.0_131 or later). However, for example, if an older Zoomdata server you have installed is running Java 7, it may not be able to read the Java 8 format class files in the corresponding plug-in (e.g. Phoenix connector, etc.) and will thus error out. If this is the case, upgrading to the latest Java version should resolve the issue.

Use the java -version command on Linux to determine the Java version.

Was this topic helpful?